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What's New in this Revision? 

This is revision 1 of the Confirmit V23 CATI  Integrated Dialer Training Course, published in May 2018. The information 
herein describes Confirmit CATI Supervisor and its features as of Confirmit CATI Supervisor Build nr. 23.0.2322.0 (given 
in the CATI Supervisor Home > Help > About box). New features may be introduced into the product after this revision and 
build. Go to www.confirmit.com or check “News” on the Customer Extranet for the latest updates. The following changes 
have been made since the previous revision was published: 

• This is the first revision of the document. 



 

 

 

 

What's New in this Revision? 

Note: Only the latest changes to this documentation are listed here. Changes made to earlier revisions are listed in the 
"Changes to the User Documentation" document which can be downloaded from the Confirmit Extranet. 

The following changes have been made in revision 1 of the Confirmit Horizons v23 CATI Integrated Dialer Training Course: 

• This is the first revision of the document.  

Note: The general layout and language in this document is continually being corrected, adjusted and improved to ensure 
the user has the best possible source of information. Only NEW information and details of functionality that has changed 
since the previous issue are listed here - minor corrections to the text and document layout are not listed. 
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Dial Modes 

There are four dialing modes that can be used with the dialer. The desired mode should be specified in the CATI 
settings of the survey. 

• Manual 

• Preview 

• Automatic 

• Predictive (also includes Hybrid AKA Preview in Predictive) 

Predictive Dialing 

Predictive dialing works on the assumption that a certain percentage of numbers dialed will not be answered and so 
to be more productive it may dial more concurrent numbers than it actually has available agents to work with. A good 
predictive dialer will eliminate answer delays and minimise nuisance calls (calls that are answered without an 
interviewer to connect with). The abandon rate can be adjusted to get the best balance of high performance whilst 
keeping within an acceptable percentage of abandoned calls. 

The rate at which a predictive dialer can dial is dependent on a multitude of factors such as the time of day, the 
number of agents logged into the survey and the quality of the sample (the likelihood the numbers are to be 
answered). 

An added complexity of predictive dialing is that calls are sent to the dialer where they are queued up instead of being 
dialed straight away. 

To stay productive the dialer needs be supplied with a steady stream of calls (contact numbers) to add to its call 
queue. It is important to understand that the CATI system will only supply calls that are valid for immediate dialing. 
This means calls where all of the following are true: 

• Calls are enabled (not 'disabled' or 'disabled by quota'); 

• Calls are assigned to an interviewer or interviewer group that is currently logged in; 

• Calls have a 'time to call' property which is either now or in the past (in accordance with the time zones to 
which they belong); 

• Calls are assigned to a shift which is not currently active. 

Note: When troubleshooting call supply problems it's important to remember that whilst it might appear that 
the CATI system has a plentiful supply of calls the reality might be that very few of those calls are actually 
valid (because one or more of the conditions mentioned above is not satisfied). 

There are two views in Call Management (‘Sent to Dialer’ and ‘High Priority’) and a report (‘Distribution of Dialer 
Calls’) to help Supervisors keep track of the calls being provided. For more information on these features please refer 
to the CATI Supervisor manual. 

Hybrid Dialing 

In a predictive survey it’s possible to set some calls to be dialed in Preview mode. This can be achieved in the 
following ways. 
  

1. Via sample (using a column named ‘DialMode’). This will assign the call to be dialled with the given mode. 
(e.g. 2 for Preview). 

2. Via scheduling (using the action named ‘Set dialing mode’). Typically this is used against appointments so 
that the interviewer preview some comments captured at the previous call attempt. 
Note: This action could potentially be executed upon sample upload by loading sample with ‘Full Scheduling’ 
set. 
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3. Via Call Management. There is a column in the Call Management view labelled Dial Mode which can be 
used to search and filter calls. It is also possible to modify the value set for the dial mode by right clicking on 
the calls to bring up the context menu. The context menu provides the following options: 

a. Set Preview Dialing Mode 

b. Reset Dialing Mode 
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Dialer Survey Template Scripting 

To handle surveys where preview mode is used a condition should be added in the survey which checks the current 
dial mode and then applies appropriate actions if the dial mode is ‘Preview’ (where dial mode =2). Inside the condition 
an info node can be used to provide a preview of any existing comments captured in a previous call attempt and a 
telephony node is then used to commence execution of the dial process. 

Unlike a manually dialled survey the dialer will automatically handle the coding of certain call outcomes, for example 
no reply, busy and unobtainable. It’s recommended to either remove these options from the dial outcome question 
presented to the interviewers or to change these outcomes to be coded to some custom extended statuses so that it 
will possible to determine the status counts independently. This is especially helpful for *Voicemail and Unobtainable 
number outcomes which could potentially be coded by the dialer or the interviewer. 

Note that the dialer will only code voicemail outcomes when the answer machine detection feature is 
available/enabled on the dialer itself.  

The example shown in the image below also contains error handling for situations when the dialer returns an error 
code for the attempted call. 

 

Figure 1  Dialer specific condition in the Start Block for Preview dialing 
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Interviewer Call Delivery 

When working with an integrated dialer the interviewer ‘Task Choice’ property must be set to ‘Survey Selection’. In 
Survey Selection mode the interviewer will be able to choose from a list of assigned and open surveys upon login to 
the CATI interviewing console. Having selected a survey, calls will then be automatically delivered.  

It is possible for supervisors to override the interviewer’s ability to choose a survey by setting the ‘Automatic Survey’. 
Once an ‘Automatic Survey’ is set for an interviewer they will only be delivered calls for this survey (regardless of 
any other survey assignments they may have).   

Seamless Survey Switching is a feature which can be turned on upon request. It allows for Supervisors to switch 
interviewing agents from one survey to another without the agents needing to take any manual steps (such as logging 
out of the current survey or selecting a new survey to work on). To apply an SSS operation the supervisor should 
right click on the interviewer or interviewer group in the interviewers list and then choose ‘Change Automatic Survey’ 
(note that this option is only shown if the SSS feature setting is enabled). 
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Interviewer Settings 

• The Location property: To be used for multi-geographical locations (the location field is an optional property 
that can be set up with the dialer so that the agent can be associated with a specific local dialer gateway). 

• Dial Type, an additional field, only available when a company is working in TCPA mode. The purpose of this 
property is to set up the interviewer so that they will only dial using one of two possible modes:  

• Manually (without touching an autodialer) 

• Automatically (so that the call is sent to the autodialer to be dialled) 
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Sample Fields 

There are three special fields (reserved system fields) that can be used. The most important of these is 
‘TelephoneNumber’. The dialer will automatically dial the numbers that are included in this field. 

‘ExtensionNumber’ is an optional field that can be used to specify a caller ID for each sample contact (this will 
override any settings applied at the site or survey level). 

Provision for the required Caller IDs must be made by the Telco.  

‘Dial Type’ can be used when TCPA mode is enabled. It is used to flag the contacts as either cell phone or landline 
numbers so that once loaded into Confirmit they can be channelled to the appropriate interviewer/dialing solution (the 
number type should first be determined using a third party telephone number verification service).  
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Dialing Operation 

To work with the dialer the interviewer will be prompted for extension/telephone number at login time. The number 
entered here will be dialled the moment the OK button is selected. When the agent answers the call they will begin a 
nailed up connection with the dialer which should persist until they take a break or logout. As soon as the dialer 
connection is established the dialer will begin to make calls. When a connected call is established with a respondent 
the screen for the given interview will be popped onto the interviewers screen. 

 

Figure 2  Entering extension/telephone number at the time of logging into the Interviewer Console 
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Call Scheduling 

When dialing in predictive mode there are some situations where the dialer may return the numbers stored in its call 
queue. For example when calls have been sat in the dialer queue for an extended period of time without getting 
dialled they will be returned to the Horizons CATI system with an Extended Status of Returned dialler expired. Calls 
will also be returned by the dialer if the interviewers log out of the system or if the survey is shut down. In this case 
the calls will be returned with an Extended Status of Returned not dialled.  

By default there are no scheduling rules for calls being returned with either of these statuses and so potentially high 
volumes of calls could end up being placed into the "Not Scheduled" list. It is therefore necessary to create suitable 
rules in the survey schedule to ensure they get re-scheduled. There is a special action type ‘Restore previous call 
attributes’ which should be used to recover the call attributes as they were before being sent to the dialer and then 
another action must be applied to create a new scheduled call. 

 

Figure 3  Recovering call attributes by using the ‘Restore previous call attributes’ action  

When using the hybrid (Preview calls in a Predictive survey) it might also be helpful to place new actions into the sub-
rules for certain types of rescheduled call wherever there’s a need for the interviewer to be able to preview some call 
comments before the number is dialled (e.g. hard appointments). In this case the action type ‘Set Dial Mode’ can be 
used. 
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Live Monitoring 

Live call monitoring is performed using the ‘Interviewers List’ Activity view from within the CATI supervisor UI just as 
it would be under normal monitoring operation when working without an integrated dialer. However, when working 
with an integrated dialer, supervisors are first prompted for an extension/telephone number to be connected in order 
to be able to listen to the sound of the interviewer conversation (see the picture below). 

 

Figure 4  Entering telephone number/resource label to be monitored 
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Deferred Monitoring 

Call audio will be recorded for the whole interview if the applicable setting ‘Enable whole interview audio recording’ is 
enabled in the survey level CATI options (in the survey authoring environment). This is an accompanying setting to 
the option to enable video recording (usually both settings are turned on/off at the same time). 

• Audio files are stored on the dialler (where they will remain until they are removed/archived) 

• Video recordings are available for 30 days in the CATI Supervisor 

Supervisors can access recordings in the supervisor UI by going to the ‘Recorded Interviews’ tab. The recordings 
played from here will provide both the audio + video playback in combined synchronisation.  

Access to audio recordings (without video) is also available by going to the Call Management interface:  first choose 
View "All", then click on “Retrieve Audio” icon. Records with available recordings will be highlighted in yellow: 

 

Figure 5  Choosing interview audio recordings for playback from the Call Management UI 

Sectional Recordings 

It is possible to have sectional recordings captured for some parts of the questionnaire. This is achieved using the 
following functions contained within script nodes positioned in the survey: 

StartVoiceRecording('label') 

StartVoiceRecording is only applicable when connected to an integrated dialer. When issued inside of a script node, 
sectional voice recording will begin. This will continue to run until a StopVoiceRecording() function call is made of the 
interview finishes. It is not possible to have concurrent whole interview recording and sectional recording, if whole 
interview recording is enabled when a StartVoiceRecording() function call is made the whole interview recording will 
be stopped. The text label passed is incorporated into the filename of the .wav sound file created.  

StopVoiceRecording(stopRecordingMode: String) 

Where: 

stopRecordingMode is an optional parameter that can either be "WholeInterview", "Sectional" or "Both" e.g. 
StopVoiceRecording(‘Sectional’) 

StopVoiceRecording is only applicable when connected to an integrated dialer. When issued inside of a script node, if 
voice recording is enabled for this interview then the specified voice recording type will be stopped on the dialer, if no 
value is supplied the default is “Both”. 

To access a recording simply right click on the appropriate record and then choose the menu option to play the audio. 
The recordings of each call attempt and any sectional recordings (if captured) are then presented as a list in a new 
window: 

 

Figure 6  UI provided for choosing a recording to play back from the Recorded Interviews 

Call recordings are also accessible from within the CATI Reviewer interface 



Confirmit Confidential Confirmit CATI Integrated Dialer Training Course 

– 11 – 

Reporting 

In a predictive campaign there is a special report available from the context menu in the surveys list: ‘Distribution of 
Dialler Calls’. This report shows the periodical provision of sample contacts to the dialer when operating in predictive 
mode.  

 

Figure 7  Creating the Distribution of Dialer Calls report 

In the standard productivity reports the Survey Overview and Interviewer Productivity there is a filter called “Show 
dialer attempts” that can be enabled. This will include additional statistics reflecting the amount of times the dialer 
attempted to connect a call.  
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Dialer Settings 

Optional Features and Settings 

Redial and Alternative Number 
The Redial feature can be enabled as a site wide setting. When enabled, an additional button will be provided in the 
interviewer console toolbar. The button provides access to two special features: 

• Redial, this can be used when the connected call with the respondent was dropped (e.g. due to poor mobile 
reception). The redial feature allows the interviewer to execute a redial of the same telephone number in order 
to attempt to re-connect and continue the conversation. 

• The redial menu also provides an optional feature so that the interviewer can enter a new/alternative 
number to be dialled. This can be very useful when the respondent provides an alternative contact number to 
be called on.  The alternative number can be captured to an optional open text variable in the survey which 
must be named AlternativeNumber. This means the survey could be scripted to allow for this alternative 
number to be used as the new primary contact number in future call attempts. Note that the dialer will only dial 
the number in the TelephoneNumber field and so to facilitate this it will be necessary to apply some scripting 
to overwrite the original value in the TelephoneNumber field with the value in the AlternativeNumber field.  

The alternative number setting can be disabled (leaving just the redial capability) by a site level setting in the 
supervisor settings screen (access to these settings is only available to CATI admin users). 

Cancel Dialing 
Interviewers can also be permitted to cancel dialing when using either the Redial or Preview dial modes. This can be 
enabled in Supervisor > Resources > Settings > Interview Console 

This feature is especially helpful for situations where the agent can made a determination that the call should be 
disconnected but the dialer is not being sent appropriate signalling to make the same determination automatically. 

 

Figure 8  Choosing to allow interviewers to cancel the dial process 

 If the cancel dialing feature is enabled then the survey and scheduling scripts should include logic to deal 
with it (ExtendedStatusCode = 1020) 

General Dialer Settings 

There are several dialer settings which may be set as the defaults at the site wide level, under  

Supervisor > Resources > Dialer 

These settings can also be set in the "Dialer" settings tab of any given survey. Any different settings applied in the 
survey tab will override the default site wide settings. 

This is an example of the available settings although the actual settings may vary depending on the dialer being used 
and the availability of supported features. 
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Figure 9    Configuring site wide Dialer settings from the Resources (navigation) menu 

Settings at the Survey project level: 

 

Figure 10    Configuring survey level Dialer settings on the Dialer Settings tab 
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Troubleshooting 

  

1. Problems while interviewing with CATI console 

• Press F5 in CATI Console to refresh connection 

• Make sure network connectivity is stable. 

• If the network connectivity looks OK:  

• Test access to a web survey  

•  Is the web survey available?  

•  Can question responses be submitted?  

• If not, contact Confirmit Support  

  

2. Problems while logging in or dialing 

• Check if all interviewers are affected in Supervisor > Activity View > Interviewers List.  

• Can any interviewer proceed through the survey? 

• If not, look at Supervisor > Resources > Dialer and check the dialler state 

• If the dialler is disconnected, try to re-establish the connection i.e. click on “Connect and Activate” button 

• If the connection cannot be re-established proceed to the system recovery process. 

  

3. System Recovery Process 

• WS Server: IIS Manager > Application Pools: Stop ‘GenericDialerAppPool’ 

• CATI Supervisor: Resources > Dialer:  wait (up to 3 minutes) until you see the message ‘Dialer 
disconnected’ in red 

• CallGem (dialer) server: Under Control Panel > Administrative Tools > Services: 

• Stop ‘Softdial Confirmit Tunnel’ Service 

• Start ‘Softdial Confirmit Tunnel’ Service 

• WS Server: After Softdial Tunnel service has been restarted,  go to IIS Manager > Application Pools and Start 
‘GenericDialerAppPool’ 

• CATI Supervisor: Connect and activate the dialler in CATI Supervisor > Resources > Dialer > Click on 
“Connect and Activate Dialer” button 


